1-160q4223412-50

【系统环境】Centos 7.1 64位

今天安装docker最新版过程中遇到一个报错显示

正在解决依赖关系
–> 正在检查事务
—> 软件包 docker-engine-selinux.noarch.0.1.12.3-1.el7.centos 将被 安装
–> 处理 docker-engine-selinux-1.12.3-1.el7.centos.noarch 与 docker-selinux 的冲突
–> 解决依赖关系完成
错误:docker-engine-selinux conflicts with docker-selinux-1.10.3-46.el7.centos.14.x86_64
 您可以尝试添加 –skip-broken 选项来解决该问题
 您可以尝试执行:rpm -Va –nofiles –nodigest


经过一段时间google终于解决了问题分享给大家

qq%e6%88%aa%e5%9b%be20161028145642

因为安装这个docker版本之前安装的docker-io版本虽然之前已经yum  remove docker 但是还是有残留

1.查看已经安装的docker版本

yum list installed|grep docker

2.移除相关docker软件

yum remove docker-selinux.x86_64 -y

再次安装docker就成功了

欢迎留言