docker 启动报错解决

1,228次阅读
没有评论

docker 启动报错解决

今天用 docker 启动报错
Cannot connect to the Docker daemon. Is ‘docker -d’ running on this host?

意思是 docker -d 查看

docker 启动报错解决

[root@localhost ~]# docker -d
WARN[0000] You are running linux kernel version 2.6.32-573.22.1.el6.x86_64, which might be unstable running docker. Please upgrade your kernel to 3.10.0.
INFO[0000] Listening for HTTP on unix (/var/run/docker.sock)
ERRO[0000] [graphdriver] prior storage driver “aufs” failed: driver not supported
FATA[0000] Error starting daemon: error initializing graphdriver: driver not supported 意思是内核版本过低

解决方法:

编辑 /etc/grub.conf 启动菜单 查看 3.0 内核位置我的位置为 1 改为 1 然后重启就 Ok 了

docker 启动报错解决

重启之后 uname -r 内核版本就是 3.0 了

docker 启动报错解决

然后启动 docker 就不会报错了 docker 报错原因很多这只是其中一种。看清楚是不是自己遇到的问题 (づ~3~) づ╭❤~

禁止转载:by:xiaoyin

QQ:1500698928

 

正文完
 
ddn
版权声明:本站原创文章,由 ddn 2016-04-07发表,共计619字。
转载说明:除特殊说明外本站文章皆由CC-4.0协议发布,转载请注明出处。